$re = '/(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)/m';
$str = 'emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);