using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)";
string input = @"emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}