package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(emplacement|implantation) (n\s?°|n|numero|\W)(\s?1\s?bis)`)
var str = `emplacement n1bis
emplacement n 1bis
emplacement n°1bis
emplacement n° 1bis
emplacement numero 1bis
emplacement numero 1 bis
implantation : 1bis`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}