#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sUi)\[p\](.+)\[p\]"
Local $sString = "[p]Получить ответ можно двумя способами[p]" & @CRLF & _
"[тег]самому задать вопрос[/тег]" & @CRLF & _
"[p]Получить ответ можно двумя способами[p]" & @CRLF & _
"" & @CRLF & _
"[p]Получить ответ можно двумя способами" & @CRLF & _
"Получить ответ можно двумя способами[p]" & @CRLF & _
"" & @CRLF & _
"[p]Получить ответ можно двумя способами[p]" & @CRLF & _
"[тег]самому задать вопрос[/тег]" & @CRLF & _
"" & @CRLF & _
"[p]Получить ответ можно двумя способами[p]"
Local $sSubst = "<p>$1</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)