import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"\[p\](.+)\[p\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами
Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p>$1</p>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)