use strict;
my $str = '[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами
Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]';
my $regex = qr/\[p\](.+)\[p\]/sip;
my $subst = '<p>$1</p>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";