re = /\[p\](.+)\[p\]/i
str = '[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами
Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]'
subst = '<p>$1</p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result