$re = '/\[p\](.+)\[p\]/sUi';
$str = '[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами
Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]';
$subst = "<p>$1</p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;