import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[p\\](.+)\\[p\\]";
final String string = "[p]Получить ответ можно двумя способами[p]\n"
+ "[тег]самому задать вопрос[/тег]\n"
+ "[p]Получить ответ можно двумя способами[p]\n\n"
+ "[p]Получить ответ можно двумя способами\n"
+ "Получить ответ можно двумя способами[p]\n\n"
+ "[p]Получить ответ можно двумя способами[p]\n"
+ "[тег]самому задать вопрос[/тег]\n\n"
+ "[p]Получить ответ можно двумя способами[p]";
final String subst = "<p>$1</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}