#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*\/folder\/[A-Za-z0-9-]*\?)\D+\d+=\D+\d+=\D+\d+&\D+\d+$"
Local $sString = "domain.com/folder/random-text-2?A1=A2=A3&A4" & @CRLF & _
"domain.com/folder/random-text-2?B1=B2=B3&B4"
Local $sSubst = "$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)