// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*\/folder\/[A-Za-z0-9-]*\?)\D+\d+=\D+\d+=\D+\d+&\D+\d+$").unwrap();
let string = "domain.com/folder/random-text-2?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4";
let substitution = "$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}