const regex = /^(.*\/folder\/[A-Za-z0-9-]*\?)\D+\d+=\D+\d+=\D+\d+&\D+\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\\/folder\\\/[A-Za-z0-9-]*\\?)\\D+\\d+=\\D+\\d+=\\D+\\d+&\\D+\\d+$', 'gm')
const str = `domain.com/folder/random-text-2?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4`;
const subst = `$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);