$re = '/^(.*\/folder\/[A-Za-z0-9-]*\?)\D+\d+=\D+\d+=\D+\d+&\D+\d+$/m';
$str = 'domain.com/folder/random-text-2?A1=A2=A3&A4
domain.com/folder/random-text-2?B1=B2=B3&B4';
$subst = "$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;