import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*\\/folder\\/[A-Za-z0-9-]*\\?)\\D+\\d+=\\D+\\d+=\\D+\\d+&\\D+\\d+$";
final String string = "domain.com/folder/random-text-2?A1=A2=A3&A4\n"
+ "domain.com/folder/random-text-2?B1=B2=B3&B4";
final String subst = "$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}