# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*\/folder\/[A-Za-z0-9-]*\?)\D+\d+=\D+\d+=\D+\d+&\D+\d+$"
test_str = ("domain.com/folder/random-text-2?A1=A2=A3&A4\n"
"domain.com/folder/random-text-2?B1=B2=B3&B4")
subst = "$1REPLACED-1=REPLACED-2=REPLACED-3&REPLACED-4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.