#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<body[^>]*>)()"
Local $sString = "<body tag>" & @CRLF & _
"<body" & @CRLF & _
" tag- oh no it matched across" & @CRLF & _
" multiple lines>" & @CRLF & _
"<body alink="some_image_name_with_<brackets>_.png" >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")