using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<body[^>]*>)()";
string input = @"<body tag>
<body
tag- oh no it matched across
multiple lines>
<body alink=""some_image_name_with_<brackets>_.png"" >";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}