import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<body[^>]*>)()";
final String string = "<body tag>\n"
+ "<body\n"
+ " tag- oh no it matched across\n"
+ " multiple lines>\n"
+ "<body alink=\"some_image_name_with_<brackets>_.png\" >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}