$re = '/(<body[^>]*>)()/m';
$str = '<body tag>
<body
tag- oh no it matched across
multiple lines>
<body alink="some_image_name_with_<brackets>_.png" >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);