#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$"
Local $sString = "/some-page/12/any-string" & @CRLF & _
"/some-page/12/any-string/" & @CRLF & _
"/some-page/12/any-string/some-string" & @CRLF & _
"/some-page/12/any-string/some-string/" & @CRLF & _
"/some-page/12/" & @CRLF & _
"/some-page/245/any-string/registration-form" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")