import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "some-page\\/(\\d+)\\/([^\\/\\n]+)(?:\\/(?!registration-form$).*)?$";
final String string = "/some-page/12/any-string\n"
+ "/some-page/12/any-string/\n"
+ "/some-page/12/any-string/some-string\n"
+ "/some-page/12/any-string/some-string/\n"
+ "/some-page/12/\n"
+ "/some-page/245/any-string/registration-form\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}