import re
regex = re.compile(r"some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$", flags=re.MULTILINE)
test_str = ("/some-page/12/any-string\n"
"/some-page/12/any-string/\n"
"/some-page/12/any-string/some-string\n"
"/some-page/12/any-string/some-string/\n"
"/some-page/12/\n"
"/some-page/245/any-string/registration-form\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")