import Foundation
let pattern = #"some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/some-page/12/any-string
/some-page/12/any-string/
/some-page/12/any-string/some-string
/some-page/12/any-string/some-string/
/some-page/12/
/some-page/245/any-string/registration-form
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)