re = /some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$/m
str = '/some-page/12/any-string
/some-page/12/any-string/
/some-page/12/any-string/some-string
/some-page/12/any-string/some-string/
/some-page/12/
/some-page/245/any-string/registration-form
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end