using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$";
string input = @"/some-page/12/any-string
/some-page/12/any-string/
/some-page/12/any-string/some-string
/some-page/12/any-string/some-string/
/some-page/12/
/some-page/245/any-string/registration-form
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}