const regex = /some-page\/(\d+)\/([^\/\n]+)(?:\/(?!registration-form$).*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('some-page\\\/(\\d+)\\\/([^\\\/\\n]+)(?:\\\/(?!registration-form$).*)?$', 'gm')
const str = `/some-page/12/any-string
/some-page/12/any-string/
/some-page/12/any-string/some-string
/some-page/12/any-string/some-string/
/some-page/12/
/some-page/245/any-string/registration-form
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}