# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\s*(<head>|<\\/head>)//gm;t' <<< "<html>
<head>
</head>
<div>
<!-- some content -->
</div>
</html>"