#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n\s*(<head>|<\/head>)"
Local $sString = "<html>" & @CRLF & _
" <head>" & @CRLF & _
" </head>" & @CRLF & _
" <div>" & @CRLF & _
" <!-- some content -->" & @CRLF & _
" </div>" & @CRLF & _
"</html>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)