package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n\s*(<head>|<\/head>)`)
var str = `<html>
<head>
</head>
<div>
<!-- some content -->
</div>
</html>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}