import re
regex = re.compile(r"\n\s*(<head>|<\/head>)", flags=re.MULTILINE)
test_str = ("<html>\n"
" <head>\n"
" </head>\n"
" <div>\n"
" <!-- some content -->\n"
" </div>\n"
"</html>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)