$re = '/\n\s*(<head>|<\/head>)/m';
$str = '<html>
<head>
</head>
<div>
<!-- some content -->
</div>
</html>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;