use strict;
my $str = '<html>
<head>
</head>
<div>
<!-- some content -->
</div>
</html>';
my $regex = qr/\n\s*(<head>|<\/head>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";