# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=^(\((?:\w+\h*|(?1)\h*)*+\))$)(\()|(?<!^)\G(?:(\w+)(?=\h*\))|(\w+)|\h*|(\()|(\))(?=\h*[\w(])|(\)))/${2:+[}${3:+'$3'}${4:+'$4', }${5:+[}${6:+], }${7:+]}/gm;t' <<< "(10 AND 20 AND (30 OR (40 AND 50)))
Into
['10', 'AND', '20', 'AND', ['30', 'OR', ['40', 'AND', '50']]]"