$re = '/(?=^(\((?:\w+\h*|(?1)\h*)*+\))$)(\()|(?<!^)\G(?:(\w+)(?=\h*\))|(\w+)|\h*|(\()|(\))(?=\h*[\w(])|(\)))/m';
$str = '(10 AND 20 AND (30 OR (40 AND 50)))
Into
[\'10\', \'AND\', \'20\', \'AND\', [\'30\', \'OR\', [\'40\', \'AND\', \'50\']]]';
$subst = "${2:+[}${3:+'$3'}${4:+'$4', }${5:+[}${6:+], }${7:+]}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;