#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=^(\((?:\w+\h*|(?1)\h*)*+\))$)(\()|(?<!^)\G(?:(\w+)(?=\h*\))|(\w+)|\h*|(\()|(\))(?=\h*[\w(])|(\)))"
Local $sString = "(10 AND 20 AND (30 OR (40 AND 50)))" & @CRLF & _
"" & @CRLF & _
"Into" & @CRLF & _
"" & @CRLF & _
"['10', 'AND', '20', 'AND', ['30', 'OR', ['40', 'AND', '50']]]"
Local $sSubst = "${2:+[}${3:+'$3'}${4:+'$4', }${5:+[}${6:+], }${7:+]}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)