using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^(\((?:\w+\h*|(?1)\h*)*+\))$)(\()|(?<!^)\G(?:(\w+)(?=\h*\))|(\w+)|\h*|(\()|(\))(?=\h*[\w(])|(\)))";
string substitution = @"${2:+[}${3:+'$3'}${4:+'$4', }${5:+[}${6:+], }${7:+]}";
string input = @"(10 AND 20 AND (30 OR (40 AND 50)))
Into
['10', 'AND', '20', 'AND', ['30', 'OR', ['40', 'AND', '50']]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}