import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^(\\((?:\\w+\\h*|(?1)\\h*)*+\\))$)(\\()|(?<!^)\\G(?:(\\w+)(?=\\h*\\))|(\\w+)|\\h*|(\\()|(\\))(?=\\h*[\\w(])|(\\)))";
final String string = "(10 AND 20 AND (30 OR (40 AND 50)))\n\n"
+ "Into\n\n"
+ "['10', 'AND', '20', 'AND', ['30', 'OR', ['40', 'AND', '50']]]";
final String subst = "${2:+[}${3:+'$3'}${4:+'$4', }${5:+[}${6:+], }${7:+]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}