# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+)\s(\1)(?=\s)/$1/gm;t' <<< "Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same"