import Foundation
let pattern = #"^(\w+)\s(\1)(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)