use strict;
my $str = 'Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same';
my $regex = qr/^(\w+)\s(\1)(?=\s)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";