using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\s(\1)(?=\s)";
string substitution = @"$1";
string input = @"Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}