$re = '/^(\w+)\s(\1)(?=\s)/m';
$str = 'Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;