const regex = /^(\w+)\s(\1)(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)\\s(\\1)(?=\\s)', 'gm')
const str = `Words Words are the same
correct words used
Same words used and Words are the same
Same words used and Words are the same Same`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);