#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)financial[ _]report[ _]202309\d{0,2}\.csv"
Local $sString = "financial_report_20230901.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_20230915.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_2023091.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_202309.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_20230955.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_20230801.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_20220915.csv" & @CRLF & _
"" & @CRLF & _
"financial_report_2023.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")