$re = '/financial[ _]report[ _]202309\d{0,2}\.csv/m';
$str = 'financial_report_20230901.csv
financial_report_20230915.csv
financial_report_2023091.csv
financial_report_202309.csv
financial_report_20230955.csv
financial_report_20230801.csv
financial_report_20220915.csv
financial_report_2023.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);