use strict;
my $str = 'financial_report_20230901.csv
financial_report_20230915.csv
financial_report_2023091.csv
financial_report_202309.csv
financial_report_20230955.csv
financial_report_20230801.csv
financial_report_20220915.csv
financial_report_2023.csv';
my $regex = qr/financial[ _]report[ _]202309\d{0,2}\.csv/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}