package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)financial[ _]report[ _]202309\d{0,2}\.csv`)
var str = `financial_report_20230901.csv
financial_report_20230915.csv
financial_report_2023091.csv
financial_report_202309.csv
financial_report_20230955.csv
financial_report_20230801.csv
financial_report_20220915.csv
financial_report_2023.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}