import Foundation
let pattern = #"financial[ _]report[ _]202309\d{0,2}\.csv"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
financial_report_20230901.csv
financial_report_20230915.csv
financial_report_2023091.csv
financial_report_202309.csv
financial_report_20230955.csv
financial_report_20230801.csv
financial_report_20220915.csv
financial_report_2023.csv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)