// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)financial[ _]report[ _]202309\d{0,2}\.csv").unwrap();
let string = "financial_report_20230901.csv
financial_report_20230915.csv
financial_report_2023091.csv
financial_report_202309.csv
financial_report_20230955.csv
financial_report_20230801.csv
financial_report_20220915.csv
financial_report_2023.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}