# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"financial[ _]report[ _]202309\d{0,2}\.csv"
test_str = ("financial_report_20230901.csv\n\n"
"financial_report_20230915.csv\n\n"
"financial_report_2023091.csv\n\n"
"financial_report_202309.csv\n\n"
"financial_report_20230955.csv\n\n"
"financial_report_20230801.csv\n\n"
"financial_report_20220915.csv\n\n"
"financial_report_2023.csv")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.